Remote installation fails on Windows 8 and 2012

Issue

The remote installation fails for Endpoint Agents on Windows 8 and Windows 2012 Endpoints.

Windows8Issue.png

Cause

User Account Control (UAC) in Windows 8 and Windows 2012 cannot be completely disabled. Remote Endpoint Agent installation requires that UAC is disabled on the Endpoint.

Solution

Solution #1

Add a filter policy to the Windows registry that will permit remote installation of the Endpoint Agent.

To add a filter policy using the Registry Editor:

  1. On the Endpoint machine, press CTRL+R
  2. Type regedit.exe and then click OK
  3. In the Registry Editor, navigate to the following key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  4. Locate the LocalAccountTokenFilterPolicy key. If it does not exist, create it:
    1. From the menu, select Edit >New > DWORD Value (on 64-bit systems, select Edit > New > DWORD (32-bit) Value)
    2. Type LocalAccountTokenFilterPolicy, and then press ENTER
  5. Right-click LocalAccountTokenFilterPolicy, and then click Modify
  6. Change the value data to 1, and then click OK
  7. Close the Registry Editor

Finally, run the remote installation procedure from the Management Console.

Solution #2

Create an Endpoint Agent installer and install it locally on the Endpoint. To create an Endpoint installer, please refer to procedure #1 in the topic, "Deploying the Endpoint Agent."

Solution #3

Disable User Account Control in the Windows Registry on the Endpoints.

To disable UAC using the Registry Editor:

  1. On the Endpoint machine, press CTRL+R
  2. Type regedit.exe and then click OK
  3. In the Registry Editor, navigate to the following key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA
  4. Change the value for EnableLUA to 1
  5. Restart the Endpoint computer

Finally, run the remote installation procedure from the Management Console.